Runboard.com
You're welcome.
Australian X-Trail Website Members Rides

Site Search

Facebook Aussie Forum Website Twitter Aussie Forum Website YouTube Aussie Forum Website Flickr PhotoBucket MSN Messenger Skype RSS Feed Events Calendar Admin Mailbox Nissan Australia myNissan Capped Service Fuel Consumption Monitor Tyre Size Calculator Australian X-TRAIL Forum Live Chat

Forum Rules   
   Register for a free global account (learn about it) | LOG IN: globally (click here) (Lost Password?)

 
Nickelass Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL NEWBIE
 


Date Registered: 02-2021
TOTAL POSTS: 72
Reply | QUOTE
Anyone fix a single LED that's gone in X-Trail T31 Rear LED High Brake Light Lamp array?


Part number: 26590-1DA0B-A124

Looks like a single LED is out in the my Rear LED High Brake Light Lamp. Anyone tried to fix this, or would you have to order a whole new unit or salvo from the wreckers and install it myself (no idea how hard/easy it would be)?

Ebay Item: New Geniune Nissan X Trail XTrail X-Trail T31 Rear LED High Brake Light Lamp

Admin Edit ebay link removed as per forum policy

Last edited by Revhead Kev, 29/Apr/2021, 11:18 am


---
Nick
2010 ST (MY10). ** MODIFIED*** King lifted springs, Rear protection tray, Sony XAV-AX1000 headunit, CMD05 Command parking sensors, Garnish Mount reversing camera, Tow bar, Left side cargo drawer, ClicOn dash mobile mount
29/Apr/2021, 10:10 am Link to this post Send Email PM   Send Private Message Blog
 


Reply





You are not logged in (login)

forum sticker
Back to top Back to top

Back to top

<-- end container -->