Runboard.com
You're welcome.
Australian X-Trail Website Members Rides

Site Search

Facebook Aussie Forum Website Twitter Aussie Forum Website YouTube Aussie Forum Website Flickr PhotoBucket MSN Messenger Skype RSS Feed Events Calendar Admin Mailbox Nissan Australia myNissan Capped Service Fuel Consumption Monitor Tyre Size Calculator Australian X-TRAIL Forum Live Chat

Forum Rules   
   Register for a free global account (learn about it) | LOG IN: globally (click here) (Lost Password?)

 
Fairmont Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL NEWBIE
 


Date Registered: 02-2021
TOTAL POSTS: 4
Reply | QUOTE
T32 Stalls


Hi all,

CVT T32 randomly stalls when ideling at lights etc. The idle doesn't seem right. I've noticed that it seems to happen shortly after turning on the car from cold start. We would generally let it idle for a minute or so before driving but still stalls randomly thereafter. I don't recall it stalling when driving from a warm start. We have had the car for 2 years with no issues until the last few months.

I've cleaned throttle body, reset throttle body, used injector cleaner, currently using 98, serviced recently, air filter is clean, no air leaks that I can hear, spark plugs and coils are good, fuel filter is maintenance free item and not getting check engine light. Mechanic put on the computer with no issues.

Running out of ideas!!

I've read the T30 had cam and crank sensor issues. Could this be the problem?

Any ideas is appreciated.
13/Apr/2021, 9:00 pm Link to this post Send Email PM   Send Private Message Blog
 
Revhead Kev Profile
Live feed
Blog
Friends
Miscellaneous info



Date Registered: 10-2006
Location: Mona Vale, Sydney, AUSTRALIA
TOTAL POSTS: 6002
Reply | QUOTE
Re: T32 Stalls


How many kms has the engine done ?

---
Kev X450(c) T30 Guru
03 Titanium Ti T30 Series 1 **MODIFIED**
My Blog
My CarPC Worklog
13/Apr/2021, 11:07 pm Link to this post Send Email PM   Send Private Message Blog
 
Fairmont Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL NEWBIE
 


Date Registered: 02-2021
TOTAL POSTS: 4
Reply | QUOTE
Re: T32 Stalls


About 52000km. It's a QR25DE engine. Car restarts and runs fine afterwards.
I also followed the steps to relearn idle, throttle etc: https://youtu.be/CR-AjHCslhs

Last edited by Fairmont, 14/Apr/2021, 7:49 am
14/Apr/2021, 6:11 am Link to this post Send Email PM   Send Private Message Blog
 
Revhead Kev Profile
Live feed
Blog
Friends
Miscellaneous info



Date Registered: 10-2006
Location: Mona Vale, Sydney, AUSTRALIA
TOTAL POSTS: 6002
Reply | QUOTE
Re: T32 Stalls


I would recommend replacing the cam and crank sensors as another item to check off the list of probable causes as they are relatively cheap and do still have a habit of causing issues in the QR25DE.
Always do them as a set, OEM only.

---
Kev X450(c) T30 Guru
03 Titanium Ti T30 Series 1 **MODIFIED**
My Blog
My CarPC Worklog
14/Apr/2021, 8:34 am Link to this post Send Email PM   Send Private Message Blog
 


Reply





You are not logged in (login)

forum sticker
Back to top Back to top

Back to top

<-- end container -->