Runboard.com
You're welcome.
Australian X-Trail Website Members Rides

Site Search

Facebook Aussie Forum Website Twitter Aussie Forum Website YouTube Aussie Forum Website Flickr PhotoBucket MSN Messenger Skype RSS Feed Events Calendar Admin Mailbox Nissan Australia myNissan Capped Service Fuel Consumption Monitor Tyre Size Calculator Australian X-TRAIL Forum Live Chat

Forum Rules   
   Register for a free global account (learn about it) | LOG IN: globally (click here) (Lost Password?)

 
digsy123 Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL NEWBIE
 


Date Registered: 10-2019
TOTAL POSTS: 1
Reply | QUOTE
T31 2.0L petrol 2WD CVT loss of power. when starting engine all i hear are clicks


Hi Guys,

Strange problem today with my T31 x-trail .

Car suddenly lost power as i was costing towards red lights. put my foot to the floor and the car seemed to just limp at 10kmh. Pulled over and turned off engine and restarted. Everything seemed fine after. Drove about 20 mins to petrol station and filled up.

As i was driving away from the petrol station the problem happened again, no power car just limping.

turned off engine, tried restarting and all i get is strange clicking noise. Thought it was battery but still clicks when i got a jump start. if i leave it for 5 mins, the engine cracks for 1-2 secs then clicks.

Any ideas?

T31 Xtrail St 2WD, CVT 2L petrol MR20DE

Thanks in advance
23/Oct/2019, 9:22 pm Link to this post Send Email PM   Send Private Message Blog
 
marcelocwb Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL NEWBIE
 


Date Registered: 07-2018
Location: Curitiba
TOTAL POSTS: 27
Reply | QUOTE
Re: T31 2.0L petrol 2WD CVT loss of power. when starting engine all i hear are clicks


Limping can happen when cvt oil is to hot or old.
Check the level according with service manual. There is a correct procedure.

But the clicking can be other bigger problem. Hard to discover by internet. Try to lift the four wheels from ground and ask some one to put in "D", "L" "4wd" and "lock".
Go around the car and try to find the "click" source.


---
Marcelo
T31 LE Petrol MR20DE 2.0 4FWD 2009 Black
20/Jul/2020, 4:08 am Link to this post Send Email PM   Send Private Message Blog
 


Reply





You are not logged in (login)

forum sticker
Back to top Back to top

Back to top

<-- end container -->