Runboard.com
You're welcome.
Australian X-Trail Website Members Rides

Site Search

Facebook Aussie Forum Website Twitter Aussie Forum Website YouTube Aussie Forum Website Flickr PhotoBucket MSN Messenger Skype RSS Feed Events Calendar Admin Mailbox Nissan Australia myNissan Capped Service Fuel Consumption Monitor Tyre Size Calculator Australian X-TRAIL Forum Live Chat

Forum Rules   
   Register for a free global account (learn about it) | LOG IN: globally (click here) (Lost Password?)

 
Jac M Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL NEWBIE
 


Date Registered: 12-2015
TOTAL POSTS: 3
Reply | QUOTE
Trailer LED Lights


Hi folks,

I have a T32 Xtrail mis 2015 build. Recently I upgraded my box trailer lights to LED ones thinking that the upgrade would be simple enough - which it was, however...

The new lights do not work at all on the Xtrail (the old one did though). The car also wont run another trailer with LED lights. To prove the point, A 2015 build Landcruiser runs both sets of lights with out a problem.

Do others experience the same problem - is there a trick to this system? Any ideas?
Cheers
John

---
Jac M
South Coast NSW
T32 Xtrail - 2015
Member # X-4599
23/Mar/2016, 8:59 am Link to this post Send Email PM   Send Private Message Blog
 
BPxtrail Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL ENTHUSIAST
 


Date Registered: 08-2013
Location: Canberra
TOTAL POSTS: 121
Reply | QUOTE
Re: Trailer LED Lights


Had this problem with my 2013 T31.
Found it to be a bad earth connection in the dealer fitted tow bar wiring, ie. No trailer lights until I actually hooked up the trailer to the tow ball. Then got earthing from the metal-to-metal contact.
Tested with a multimeter and found a poor connection in the wiring loom, but it took a while.
Also, don't forget that LED lights are polarity sensitive, ie. Negative must be connected to earth. Won't work if reversed.

---
2013 ST, T31 Series 5. Aug, 2013
24/Mar/2016, 9:22 pm Link to this post Send Email PM   Send Private Message
 
Jac M Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL NEWBIE
 


Date Registered: 12-2015
TOTAL POSTS: 3
Reply | QUOTE
Re: Trailer LED Lights


Finally fixed today - it turns out that a module (part of the tow bar and the electrics kit) failed and needed to be replaced. The trailer lights now work as they should.

Cheers

---
Jac M
South Coast NSW
T32 Xtrail - 2015
Member # X-4599
4/May/2016, 5:56 pm Link to this post Send Email PM   Send Private Message Blog
 


Reply





You are not logged in (login)

forum sticker
Back to top Back to top

Back to top

<-- end container -->