Runboard.com
You're welcome.
Australian X-Trail Website Members Rides

Site Search

Facebook Aussie Forum Website Twitter Aussie Forum Website YouTube Aussie Forum Website Flickr PhotoBucket MSN Messenger Skype RSS Feed Events Calendar Admin Mailbox Nissan Australia myNissan Capped Service Fuel Consumption Monitor Tyre Size Calculator Australian X-TRAIL Forum Live Chat

Forum Rules   
   Register for a free global account (learn about it) | LOG IN: globally (click here) (Lost Password?)




Page:
 1  2 

 
philsmith Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL NEWBIE
 


Date Registered: 05-2013
TOTAL POSTS: 10
Reply | QUOTE
Re: Re:


Update- No i'm hairless from pulling it out I went down the route of using the local dealer, don't know why I bothered, they said the oil was low??? did a idle relearn but no error codes and that was it..$200 thank you very much.

But its still stalling. Took it for a ride the wknd and have narrowed it down to when its going up a hill and stalls when the accelerator is released. Has any one heard of someone changing the cam sensors and they were faulty...reading the forums it sounds just like the sensors ares not working..the one thing I haven't done yet is fuel filter but surely if it was that it would do it more often and run really bad, which it doesnt.


Please help!
14/Mar/2014, 10:47 am Link to this post Send Email PM   Send Private Message Blog
 
Revhead Kev Profile
Live feed
Blog
Friends
Miscellaneous info



Date Registered: 10-2006
Location: Mona Vale, Sydney, AUSTRALIA
TOTAL POSTS: 5973
Reply | QUOTE
Re: HELP!!? 2002 xtrail TI keeps cutting out...


How many K's has the Xtrail done ?
It could be the injectors needing cleaning or the fuel pump pressure a bit low, maybe because of a blocked filter.

---
Kev X450(c) T30 Guru
03 Titanium Ti T30 Series 1 **MODIFIED**
My Blog
My CarPC Worklog
14/Mar/2014, 5:08 pm Link to this post Send Email PM   Send Private Message Blog
 
cooch t31 Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL HOLIC
 


Date Registered: 06-2008
Location: Blue Mountains, NSW
TOTAL POSTS: 5966
Reply | QUOTE
Re:


It sounds like the sensors again.

I in the past have purchased a new regulator for my old Ford and still couldn't get the generator to charge the battery, I reco'd the geny, new battery, and almost brought a new solenoid when I decided to take it to a auto electrician mate of mine.
He too was stumped and we came to the conclusion after 1 hour of diagnosis that the regulator wasn't quite right, I went and brought a new regulator and hey presto.

Just because it's new doesn't mean it's going to work.

Last edited by cooch t31, 15/Mar/2014, 9:59 am


---
Tony X-891c

HERE is my D22 Navara
HERE is my old 2008 T31, ST Series1

15/Mar/2014, 8:03 am Link to this post Send Private Message
 
philsmith Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL NEWBIE
 


Date Registered: 05-2013
TOTAL POSTS: 10
Reply | QUOTE
Re: HELP!!? 2002 xtrail TI keeps cutting out...


Hey guys, the cars done about 142k. I drove it up some steep hills trying to make it go, when it's in 2nd it's fine, higher revs etc, but as soon as I put it in drive bam, cuts out.

Strange, what's the best way to check fuel pressure or clean the injectors?

16/Mar/2014, 2:42 pm Link to this post Send Email PM   Send Private Message Blog
 
duckhux Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL NEWBIE
 


Date Registered: 12-2014
Location: Innisfail 4860
TOTAL POSTS: 10
Reply | QUOTE
Re: HELP!!? 2002 xtrail TI keeps cutting out...


my auto electrician says always come to him first. modern cars such an electrical nightmare and taking to mechanics first can end up messing up the original problem ! same sort problem
(only one in 295,000) was ??? (fuel advisor) . analyses how much fuel required for acceleration. used to just stop and not start untill IT decided it was ready. cost around $70 from spare parts NOT dealer.




---
duckhux
2/Jan/2015, 11:23 am Link to this post Send Email PM   Send Private Message Blog
 


Reply




Page:
 1  2 





You are not logged in (login)

forum sticker
Back to top Back to top

Back to top

<-- end container -->