Runboard.com
You're welcome.
Australian X-Trail Website Members Rides

Site Search

Facebook Aussie Forum Website Twitter Aussie Forum Website YouTube Aussie Forum Website Flickr PhotoBucket MSN Messenger Skype RSS Feed Events Calendar Admin Mailbox Nissan Australia myNissan Capped Service Fuel Consumption Monitor Tyre Size Calculator Australian X-TRAIL Forum Live Chat

Forum Rules   
   Register for a free global account (learn about it) | LOG IN: globally (click here) (Lost Password?)

 
Tamsus Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL NEWBIE
 


Date Registered: 05-2009
TOTAL POSTS: 9
Reply | QUOTE
T30 Climate control lights


Problem I have is that the LEDs backlights in the climate control unit of my series 1 T30 no longer work.

I took the climate control unit out the other day because for some months some of the lights were no longer working. Unscrewed the bezel from the circuit board, noted that they were LEDs and blue in colour, type unknown and decided I had to do a bit more research on them so put everyting back together. Now none of the lights work!

Anyone have a similar problem and can offer any help? My first guess was a blown fuse but I checked that out.
5/May/2009, 8:06 pm Link to this post Send Email PM   Send Private Message
 
Revhead Kev Profile
Live feed
Blog
Friends
Miscellaneous info



Date Registered: 10-2006
Location: Mona Vale, Sydney, AUSTRALIA
TOTAL POSTS: 5809
Reply | QUOTE
Re: T30 Climate control lights


Hi Tamsus,

The globes are not LED but rather small pigtail globes with a blue sleeve over them.
They have their long leads wrapped around the plastic holder which you will have to separate before fitting the new globe into the same holder.

I got a pair for my Series 1 recently from Jaycar.
They refer to them as Mini Globes and the part number is SL-2685 for the 12V 3mm diameter 7mm long ones.
I have not put them in yet but seem to be the correct size. I will try to put them in this week and report back on how they fit.

---
Kev X450(c) T30 Guru
03 Titanium Ti T30 Series 1 **MODIFIED**
My Blog
My CarPC Worklog
5/May/2009, 11:29 pm Link to this post Send Email PM   Send Private Message Blog
 
Tamsus Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL NEWBIE
 


Date Registered: 05-2009
TOTAL POSTS: 9
Reply | QUOTE
posticon Re: T30 Climate control lights


Got those 12V rice globes from Jaycar. Ones with yellow leads. Using small side-cutters I cut the metal leads away from each other, stripped the wires of insulation and then took off the silicone around the leads. Using a Dremel drill I bored-out the holes for the leads in the globe holders. Pushed the globes into the holders as far as they would go and wrapped the wires a few times around the grooves in the holders. Placed the blue sleeve back over the globes, reinserted the globes into climate control unit and everything is working fine.
17/May/2009, 11:22 pm Link to this post Send Email PM   Send Private Message
 
Revhead Kev Profile
Live feed
Blog
Friends
Miscellaneous info



Date Registered: 10-2006
Location: Mona Vale, Sydney, AUSTRALIA
TOTAL POSTS: 5809
Reply | QUOTE
Re: T30 Climate control lights


Great work Tamsus

---
Kev X450(c) T30 Guru
03 Titanium Ti T30 Series 1 **MODIFIED**
My Blog
My CarPC Worklog
19/May/2009, 5:27 pm Link to this post Send Email PM   Send Private Message Blog
 


Reply





You are not logged in (login)

forum sticker
Back to top Back to top

Back to top

<-- end container -->