Runboard.com
You're welcome.
Australian X-Trail Website Members Rides

Site Search

Facebook Aussie Forum Website Twitter Aussie Forum Website YouTube Aussie Forum Website Flickr PhotoBucket MSN Messenger Skype RSS Feed Events Calendar Admin Mailbox Nissan Australia myNissan Capped Service Fuel Consumption Monitor Tyre Size Calculator Australian X-TRAIL Forum Live Chat

Forum Rules   
   Register for a free global account (learn about it) | LOG IN: globally (click here) (Lost Password?)

 
rossguzzi Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL NEWBIE
 


Date Registered: 03-2017
TOTAL POSTS: 16
Reply | QUOTE
T30 nearly dies after starting.


My 04 T3o with 140 000 km runs really nice except sometimes it nearly dies just after starting it. Once, last week after 40 minute drive on the freeway it actually died twice after starting. Third time I added a bit of accelerator and it went fine.

I thought of changing the cam and crank sensor but a Repco service center I rang said unless I have a check light come on not to bother changing them. He thought it would just be a idle reset.
So after $100 for a idle reset, which the car did not accept, either with the scan tool or manually, I still have the problem.
He suggested the throttle body could be at fault. $550 - $600 to replace with new.

Should I just change out the sensors ? Or book it into Nissan.

I have, new plugs, oil, K&N air filter, cleaned MAF.

Advise welcome.

---
Ross
X-5057
2004 TI
10/Jun/2017, 1:16 am Link to this post Send Email PM   Send Private Message Blog
 
Revhead Kev Profile
Live feed
Blog
Friends
Miscellaneous info



Date Registered: 10-2006
Location: Mona Vale, Sydney, AUSTRALIA
TOTAL POSTS: 5975
Reply | QUOTE
Re: T30 nearly dies after starting.


Firstly, you should search for your topic before duplicating posts which have already been discussed.

Secondly, replace the sensors. Sometimes faults are there which are intermittent and the ECU does not log them until they occur multiple times in succession.

Thirdly, was the idle relearn done with aircon off and all lights off and the engine warmed up to operating temp and the pedal released relearn done ? All these conditions need to be correct to have the idle relearn procedure work.

---
Kev X450(c) T30 Guru
03 Titanium Ti T30 Series 1 **MODIFIED**
My Blog
My CarPC Worklog
11/Jun/2017, 9:37 am Link to this post Send Email PM   Send Private Message Blog
 
rossguzzi Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL NEWBIE
 


Date Registered: 03-2017
TOTAL POSTS: 16
Reply | QUOTE
Re:


Hi,
I have searched and read quite a bit about sensors etc, but this seemed a little different to what had come up on search.
I didnt do the re learn so not sure if all those things were done as you say, but they seemed to know a lot about these cars.
So I might do the sensors and see.
Thanks, good info in this site.

---
Ross
X-5057
2004 TI
11/Jun/2017, 4:22 pm Link to this post Send Email PM   Send Private Message Blog
 
rossguzzi Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL NEWBIE
 


Date Registered: 03-2017
TOTAL POSTS: 16
Reply | QUOTE
Re:


So I got 2 new sensors and installed them.

It`s still happening.

While installing them I noticed there is a bit of build up/carbon/whatever around where the butterfly shuts. Didnt want to touch or clean it because I have read horror stories about putting the TPS out.

Any recommendations ??

---
Ross
X-5057
2004 TI
19/Jul/2017, 12:17 am Link to this post Send Email PM   Send Private Message Blog
 
Revhead Kev Profile
Live feed
Blog
Friends
Miscellaneous info



Date Registered: 10-2006
Location: Mona Vale, Sydney, AUSTRALIA
TOTAL POSTS: 5975
Reply | QUOTE
Re: T30 nearly dies after starting.


You can do the idle relearn yourself as outlined here

So clean the throttle body out and then do the above to reset everything.

Last edited by Revhead Kev, 20/Jul/2017, 10:43 am


---
Kev X450(c) T30 Guru
03 Titanium Ti T30 Series 1 **MODIFIED**
My Blog
My CarPC Worklog
20/Jul/2017, 10:43 am Link to this post Send Email PM   Send Private Message Blog
 


Reply





You are not logged in (login)

forum sticker
Back to top Back to top

Back to top

<-- end container -->