Runboard.com
Слава Україні!
Australian X-Trail Website Members Rides

Site Search

Facebook Aussie Forum Website Twitter Aussie Forum Website YouTube Aussie Forum Website Flickr PhotoBucket MSN Messenger Skype RSS Feed Events Calendar Admin Mailbox Nissan Australia myNissan Capped Service Fuel Consumption Monitor Tyre Size Calculator Australian X-TRAIL Forum Live Chat

Forum Rules   
   Register for a free global account (learn about it) | LOG IN: globally (click here) (Lost Password?)

 
harley26 Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL NEWBIE
 


Date Registered: 09-2016
TOTAL POSTS: 7
Reply | QUOTE
process of elimination


Hi everyone,
Firstly let me say that I have searched exhaustively the posts on here and other forums and I have systematically progressed through the process of elimination for why my 04 x trail surges while in drive on the auto when stopped with the air con going. I have cleaned MAF, replaced cam and crank sensors, Cleaned throttle body, new air filter, replaced coilpacks and gone through the relearn procedures to no avail.
It only surges while in gear on the auto, if I slip it into neutral at traffic lights it purrs away nicely until I put back into drive. It also surges occasionally at speed.
I disconnected the o2 sensor yesterday and it made absolutely no difference so I am wondering if anyone knows whether I should have had a change in the note of the engine when I unplugged the o2 sensor like when you unplug any other sensor. If that is the case then it might be the o2 sensor causing the problem????
Any suggestions are greatly received and I think at this stage I have tried just about everything I can.
Oh also, I have a scantool and the car has not thrown any codes to date.
Cheers all.


---
Bryan
X-4802
04 t30 x trail
Cooloola Coast Qld
23/Sep/2016, 8:49 pm Link to this post Send Email PM   Send Private Message Blog
 
Heligeorge Profile
Live feed
Blog
Friends
Miscellaneous info




Date Registered: 01-2015
Location: Nicosia Cyprus
TOTAL POSTS: 39
Reply | QUOTE
Re:


If you have idling issues after cleaning the throttle body, and if you did the throttle position relearn procedure without success , I think you should make a quick visit to your dealer.
He has the consult computer and can reprogram.
That's what I did .

---
X-Trail 2006 (QR20DE) 2.0L Petrol Automatic.
24/Sep/2016, 2:43 am Link to this post Send Email PM   Send Private Message Blog
 
harley26 Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL NEWBIE
 


Date Registered: 09-2016
TOTAL POSTS: 7
Reply | QUOTE
Re: Re:


Hi Heligeorge, The idle relearn was successful. It is just that it has intermittent surging when in drive which hasn't changed no matter what I try to remedy it. That is why I am thinking o2. Cheers anyway

---
Bryan
X-4802
04 t30 x trail
Cooloola Coast Qld
24/Sep/2016, 6:09 am Link to this post Send Email PM   Send Private Message Blog
 
Revhead Kev Profile
Live feed
Blog
Friends
Miscellaneous info



Date Registered: 10-2006
Location: Mona Vale, Sydney, AUSTRALIA
TOTAL POSTS: 6112
Reply | QUOTE
Re: process of elimination


Being an 04 Xtrail, if the O2 sensor has not been replaced before then I would expect it is time it was anyway.
It might also be good to replace the fuel filter too because of the Xtrail's age while you are doing things.

---
Kev X450(c) T30 Guru
03 Titanium Ti T30 Series 1 **MODIFIED**
My Blog
My CarPC Worklog
25/Sep/2016, 10:12 pm Link to this post Send Email PM   Send Private Message Blog
 
harley26 Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL NEWBIE
 


Date Registered: 09-2016
TOTAL POSTS: 7
Reply | QUOTE
Re:


Thanks Kev. Am going to order a fuel filter today and get an o2 from the wrecker just to see if it changes anything. I have noticed that the weld around o2 sensor mount seems a lot thicker than I would have imagined from factory so it may have been done in the past. At 288000 km I suppose if these things have been changed in the past it is very likely they need doing again by now anyway especially fuel filter.
Question, will a dodgy filter cause the intermittent hesitating in drive at lights and stop it when flicked to neutral? That is the part of the equation that stumps me.

Last edited by harley26, 26/Sep/2016, 7:06 am


---
Bryan
X-4802
04 t30 x trail
Cooloola Coast Qld
26/Sep/2016, 6:57 am Link to this post Send Email PM   Send Private Message Blog
 
harley26 Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL NEWBIE
 


Date Registered: 09-2016
TOTAL POSTS: 7
Reply | QUOTE
Re:


Now to top it off, today check engine light comes on and need to turn and turn it over until it kicks into life. Check engine light comes on and my scantool isn't reading any codes????


---
Bryan
X-4802
04 t30 x trail
Cooloola Coast Qld
26/Sep/2016, 11:42 am Link to this post Send Email PM   Send Private Message Blog
 
harley26 Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL NEWBIE
 


Date Registered: 09-2016
TOTAL POSTS: 7
Reply | QUOTE
Re: Re:


quote:

harley26 wrote:

Now to top it off, today check engine light comes on and need to turn and turn it over until it kicks into life. Check engine light comes on and my scantool isn't reading any codes????



Turns out it was a faulty cam sensor. replaced it with the original one and it was all good once I cleared the code. Still didn't fix the surging though. The air con compressor is starting to get noisy so I am starting to wonder if that is causing the surging because when the compressor kicks in the revs drop down and then the engine surges. I have heard somewhere a faulty air con comp can cause this type of symptom. Anyone else had this happen?


---
Bryan
X-4802
04 t30 x trail
Cooloola Coast Qld
26/Sep/2016, 5:59 pm Link to this post Send Email PM   Send Private Message Blog
 
Revhead Kev Profile
Live feed
Blog
Friends
Miscellaneous info



Date Registered: 10-2006
Location: Mona Vale, Sydney, AUSTRALIA
TOTAL POSTS: 6112
Reply | QUOTE
Re: process of elimination


The surging could be from extra fuel load not being delivered by dirty filter.
I had a faulty air con compressor and did not feel any surging.

---
Kev X450(c) T30 Guru
03 Titanium Ti T30 Series 1 **MODIFIED**
My Blog
My CarPC Worklog
27/Sep/2016, 7:35 am Link to this post Send Email PM   Send Private Message Blog
 
harley26 Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL NEWBIE
 


Date Registered: 09-2016
TOTAL POSTS: 7
Reply | QUOTE
Re: process of elimination


quote:

Revhead Kev wrote:

The surging could be from extra fuel load not being delivered by dirty filter.
I had a faulty air con compressor and did not feel any surging.




Good thought Kev. I am waiting on a filter and will see how it goes. Cheers

---
Bryan
X-4802
04 t30 x trail
Cooloola Coast Qld
27/Sep/2016, 7:47 am Link to this post Send Email PM   Send Private Message Blog
 
666rich Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL NEWBIE
 


Date Registered: 12-2016
TOTAL POSTS: 2
Reply | QUOTE
Re: process of elimination


hey harley how did you go on the surging mine does the same???
25/Feb/2017, 12:35 pm Link to this post Send Email PM   Send Private Message Blog
 


Reply





You are not logged in (login)

forum sticker
Back to top Back to top

Back to top

<-- end container -->