Runboard.com
You're welcome.
Australian X-Trail Website Members Rides

Site Search

Facebook Aussie Forum Website Twitter Aussie Forum Website YouTube Aussie Forum Website Flickr PhotoBucket MSN Messenger Skype RSS Feed Events Calendar Admin Mailbox Nissan Australia myNissan Capped Service Fuel Consumption Monitor Tyre Size Calculator Australian X-TRAIL Forum Live Chat

Forum Rules   
   Register for a free global account (learn about it) | LOG IN: globally (click here) (Lost Password?)

 
CNorth Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL NEWBIE
 


Date Registered: 08-2016
TOTAL POSTS: 4
Reply | QUOTE
posticon 2003 T30 Issues


Hi all,
Looking for some help regarding my 2003, Nissan X-trail. I bought the car less than 10 months ago, and so far have driven 2000km with it, taking it to 182 000km all up. Already had to spend 4k fixing a timing chain, and a timing cog or something. Head Gasket replaced in 2014.
After this repair, 400km later and its playing up again.
It's running rough, very jerky and when approaching an intersection it will sometimes lose all power - including power steering. Takes a while to tick over after this.
The Nissan dealer i've had the repairs at are clueless as to what could be the issue as no Error Codes appear - could be a faulty ECU? Also, an NRMA callout said it could be a problem with my immobiliser.
At the moment, they have suggested trying a higher grade of fuel.
Any ideas of the problem?

Last edited by CNorth, 27/Aug/2016, 4:42 pm
26/Aug/2016, 9:35 pm Link to this post Send Email PM   Send Private Message Blog
 
mogginator Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL NEWBIE
 


Date Registered: 08-2016
TOTAL POSTS: 13
Reply | QUOTE
Re: 2003 T30 Issues


hey mate

try running the ecu reset from one of the other posts on here i was having massive issues with fuel aswell changed this and that and wasnt getting anywhere after resetting the ecu and changing the oxygen sensor it seemed ti fix itself id try that before i start doing anything overly expensive
27/Aug/2016, 2:22 am Link to this post Send Email PM   Send Private Message Blog
 
Revhead Kev Profile
Live feed
Blog
Friends
Miscellaneous info



Date Registered: 10-2006
Location: Mona Vale, Sydney, AUSTRALIA
TOTAL POSTS: 6007
Reply | QUOTE
Re: 2003 T30 Issues


For that age, replacing the oxygen sensor and both cam and crank sensors would be a good start.

---
Kev X450(c) T30 Guru
03 Titanium Ti T30 Series 1 **MODIFIED**
My Blog
My CarPC Worklog
27/Aug/2016, 4:25 pm Link to this post Send Email PM   Send Private Message Blog
 


Reply





You are not logged in (login)

forum sticker
Back to top Back to top

Back to top

<-- end container -->