Runboard.com
You're welcome.
Australian X-Trail Website Members Rides

Site Search

Facebook Aussie Forum Website Twitter Aussie Forum Website YouTube Aussie Forum Website Flickr PhotoBucket MSN Messenger Skype RSS Feed Events Calendar Admin Mailbox Nissan Australia myNissan Capped Service Fuel Consumption Monitor Tyre Size Calculator Australian X-TRAIL Forum Live Chat

Forum Rules   
   Register for a free global account (learn about it) | LOG IN: globally (click here) (Lost Password?)


 
comitnycrym Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL NEWBIE
 

Back To Top

Date Registered: 12-2014
TOTAL POSTS: 6
Reply | QUOTE
posticon 2006 Xtrail T30 Startup/ignition issues


Hi all,

I have a 2006 T30 Xtrail 2.5 QR25DE Auto and have started to notice strange startup and rough idle on startup and when engine is cold. I changed the spark plugs over as i saw they looked in very poor condition and it seemed to improve the rough idle on a cold startup as i havent had a rough idle since changing them yesterday. however when i turn the ignition on to start the engine initially and usually from a cold startup up, it seems like it tries to fire away but struggles for a second or two until the engine comes to life and then to a normal smooth idle. Its as if its trying to find its position like its lost in its startup sequence. I also have a T31 Xtrail 2.5 Auto that my wife drives and as soon as you start that the engine comes on nicely as it should. Is this more of a cam/crank issue or possibly a ignition coil pack issue? Any help or pointers would be appreciated.
Thanks.

Edit: I wasn't getting an error code until this morning when i started driving down the road. Did the self diagnostic tool and it spat out error code "P0304 Cylinder 4 Misfire Detected". Now could this be more leaning to Ignition Coils as i have already replaced the spark plugs? The car has done approximately 204k and im unsure if the coil packs have ever been replaced at all, definitely not since i owned it when i bought it with 140k on the odometer.

Daniel.

Last edited by comitnycrym, 27/Feb/2018, 10:26 am
27/Feb/2018, 8:47 am Link to this post Send Email PM   Send Private Message Blog
 
Revhead Kev Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL HOLIC
 

Back To Top
Premium


Date Registered: 10-2006
Location: Mona Vale, Sydney, AUSTRALIA
TOTAL POSTS: 5300
Reply | QUOTE
Re: 2006 Xtrail T30 Startup/ignition issues


Easiest way to check the coilpack Daniel is to swap it over from Cyl 4 to another one and see if a different code comes up.

Last edited by Revhead Kev, 28/Feb/2018, 9:11 am


---
Kev X450(c) T30 Guru
03 Titanium Ti T30 Series 1 **MODIFIED**
My Blog
My CarPC Worklog
27/Feb/2018, 10:44 am Link to this post Send Email PM   Send Private Message Blog
 
comitnycrym Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL NEWBIE
 

Back To Top

Date Registered: 12-2014
TOTAL POSTS: 6
Reply | QUOTE
Re: 2006 Xtrail T30 Startup/ignition issues


Have just tried that, went for a short drive and couldnt get it to come up again. Maybe because the engine is warm now?
27/Feb/2018, 11:00 am Link to this post Send Email PM   Send Private Message Blog
 
Revhead Kev Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL HOLIC
 

Back To Top
Premium


Date Registered: 10-2006
Location: Mona Vale, Sydney, AUSTRALIA
TOTAL POSTS: 5300
Reply | QUOTE
Re: 2006 Xtrail T30 Startup/ignition issues


If the coilpack is intermittently faulty it may not show the code straight away, especially since you have "disturbed" the connection. Let it be for a while and monitor it.

---
Kev X450(c) T30 Guru
03 Titanium Ti T30 Series 1 **MODIFIED**
My Blog
My CarPC Worklog
28/Feb/2018, 9:12 am Link to this post Send Email PM   Send Private Message Blog
 
comitnycrym Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL NEWBIE
 

Back To Top

Date Registered: 12-2014
TOTAL POSTS: 6
Reply | QUOTE
Re: 2006 Xtrail T30 Startup/ignition issues


quote:

Revhead Kev wrote:

If the coilpack is intermittently faulty it may not show the code straight away, especially since you have "disturbed" the connection. Let it be for a while and monitor it.



Thanks. I ordered a new set of Ignition Coils as that seems to be the obvious thing to replace. Once i get them ill update the situation.
28/Feb/2018, 11:25 am Link to this post Send Email PM   Send Private Message Blog
 
comitnycrym Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL NEWBIE
 

Back To Top

Date Registered: 12-2014
TOTAL POSTS: 6
Reply | QUOTE
Re: 2006 Xtrail T30 Startup/ignition issues


quote:

Revhead Kev wrote:

Easiest way to check the coilpack Daniel is to swap it over from Cyl 4 to another one and see if a different code comes up.



Hi just an update, replaced all with new ignition coil and new spark plugs, new crankshaft and camshaft sensors and still have the problem on startup. Fault code P0304 came up again this afternoon while driving even though i put in new ignition coils. is it something more serious with the engine or is it possible maybe the Mass airflow Meter?
2/Mar/2018, 1:38 am Link to this post Send Email PM   Send Private Message Blog
 
dlpeek Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL VETERAN
 

Back To Top

Date Registered: 12-2010
Location: Macquarie Fields SYDNEY
TOTAL POSTS: 915
Reply | QUOTE
Re: 2006 Xtrail T30 Startup/ignition issues


I am no mechanic but Dr Google led me to this web [sign in to see URL] may help you!

[sign in to see URL]

cheers

---
Dave Peek
X-1756 (c)
2010 T31 ST-L (S2) CVT Precision Grey.
Tow Bar, bash plates, PEDDERS lift, YOKO GEO AT/S tyres.


2/Mar/2018, 6:53 am Link to this post Send Email PM   Send Private Message Blog
 
Wiz Au Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL ENTHUSIAST
 

Back To Top

Date Registered: 06-2017
Location: Canberra, ACT
TOTAL POSTS: 185
Reply | QUOTE
Re: 2006 Xtrail T30 Startup/ignition issues


Would think if you are still getting, and constantly getting, "Cyl 4 misfire" it's the wiring/connector to the coil then?

---
2004 T30 series II, Ti (now sold)
JRR50 Pathfinder, QD32ETi Turbo Diesel, with 'lots o fruit'.
2012 Jeep Cherokee KK CRD Limited is current ride.
Will be looking for a white or silver 2011-2013 T31 TL (Diesel) to "pimp out".
3/Mar/2018, 1:05 pm Link to this post Send Email PM   Send Private Message Blog
 


Reply





You are not logged in (login)

forum sticker
Back to top Back to top

Back to top

<-- end container -->