Runboard.com
You're welcome.
Australian X-Trail Website Members Rides

Site Search

Facebook Aussie Forum Website Twitter Aussie Forum Website YouTube Aussie Forum Website Flickr PhotoBucket MSN Messenger Skype RSS Feed Events Calendar Admin Mailbox Nissan Australia myNissan Capped Service Fuel Consumption Monitor Tyre Size Calculator Australian X-TRAIL Forum Live Chat

Forum Rules   
   Register for a free global account (learn about it) | LOG IN: globally (click here) (Lost Password?)


 
mikebrg Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL NEWBIE
 

Back To Top

Date Registered: 01-2016
Location: Kempsey NSW
TOTAL POSTS: 2
Reply | QUOTE
T31 Brake controller Issue


Hi Everyone,

I had a Brake control unit (tekonsha voyager) installed by an auto elec last week before I picked up my new camper trailer last saturday.

The issue is that when you slide the manual override inside the car the engine loses power. Has anyone ever come across this before? or knows what might be causing it?

I've had it back to the auto elec who said it works fine but later talking to him he hadn't tested it while trying to accelerate. He said that it shouldn't do that but he'd double checked all the wiring. I haven't had a chance to hook the trailer back up but before I ring him again and tell him it's still doing it I thought I'd see if anyone else has had the same problem? I don't have access to another braked trailer to test it with another trailer.

The controller works perfect in normal braking situations it's just the manual override that's interfering with something

Thanks
Mike

---
mikebrg Member ID: x-4568 2012 T31 series5 2.5L
30/Jun/2016, 1:21 pm Link to this post Send Email PM   Send Private Message Blog
 


Reply





You are not logged in (login)

forum sticker
Back to top Back to top

Back to top

<-- end container -->