Runboard.com
You're welcome.
Australian X-Trail Website Members Rides

Site Search

Facebook Aussie Forum Website Twitter Aussie Forum Website YouTube Aussie Forum Website Flickr PhotoBucket MSN Messenger Skype RSS Feed Events Calendar Admin Mailbox Nissan Australia myNissan Capped Service Fuel Consumption Monitor Tyre Size Calculator Australian X-TRAIL Forum Live Chat

Forum Rules   
   Register for a free global account (learn about it) | LOG IN: globally (click here) (Lost Password?)





Page:
 1  2  3  4 ... 7  8  9 

 
jalalski Profile
Live feed
Blog
Friends
Miscellaneous info


Back To Top
Premium



Date Registered: 02-2004
Location: SUTHERLAND, SYDNEY
TOTAL POSTS: 28797
Reply | QUOTE
Re: Malfunction Indicator (Dashboard Engine Warning Light)


Dave,

Could be the same fault experienced by our new member ]HERE Check the error the ECU is giving you by counting the blinks.

---

5/May/2008, 9:30 pm Link to this post Send Private Message MSN Blog
 
waky53 Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL ENTHUSIAST
 

Back To Top

Date Registered: 06-2005
Location: Barossa Valley
TOTAL POSTS: 284
Reply | QUOTE
Re: Malfunction Indicator (Dashboard Engine Warning Light)


OK, I did the counting the blinks thingy & got the following code

P0335 Crankshaft Position Sensor A Circuit Malfunction
is that bad?

---
Regards Dave, X162 Oct 04 Series 2 ST
Mods Strut bar_Fuel cap holder_earth wires_No door beep_Bonnet Struts_TBS_bash plate_16" Alloys_Rear sway bar_ F&R fogs
High Range 4WD Club
6/May/2008, 12:16 am Link to this post Send Email PM   Send Private Message
 
jalalski Profile
Live feed
Blog
Friends
Miscellaneous info


Back To Top
Premium



Date Registered: 02-2004
Location: SUTHERLAND, SYDNEY
TOTAL POSTS: 28797
Reply | QUOTE
Re: Malfunction Indicator (Dashboard Engine Warning Light)


emoticon Must have been crank position sensor failure day yesterday emoticon

You will need to take it to the dealer for sensor replacement just like Brad has done.

$54 sensor and $90 labour. However this fault has been covered by an official recall (check the recall thread) but at that time in 2003, it only affected series I.

Further details in ]THIS thread.

Last edited by jalalski, 6/May/2008, 7:03 am


---

6/May/2008, 7:02 am Link to this post Send Private Message MSN Blog
 
waky53 Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL ENTHUSIAST
 

Back To Top

Date Registered: 06-2005
Location: Barossa Valley
TOTAL POSTS: 284
Reply | QUOTE
Re: Malfunction Indicator (Dashboard Engine Warning Light)


Yes I looked up that recall & my Exy is outside that VIN range.
I reset the code & the light has gone out.
If there was a problem wouldn't the error code reoccur?

---
Regards Dave, X162 Oct 04 Series 2 ST
Mods Strut bar_Fuel cap holder_earth wires_No door beep_Bonnet Struts_TBS_bash plate_16" Alloys_Rear sway bar_ F&R fogs
High Range 4WD Club
6/May/2008, 9:02 pm Link to this post Send Email PM   Send Private Message
 
jalalski Profile
Live feed
Blog
Friends
Miscellaneous info


Back To Top
Premium



Date Registered: 02-2004
Location: SUTHERLAND, SYDNEY
TOTAL POSTS: 28797
Reply | QUOTE
Re: Malfunction Indicator (Dashboard Engine Warning Light)


quote:

waky53 wrote:
If there was a problem wouldn't the error code reoccur?



Yes, it will come back very soon indeed.



---

6/May/2008, 9:11 pm Link to this post Send Private Message MSN Blog
 
Mat Mat Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL ENTHUSIAST
 

Back To Top

Date Registered: 08-2009
Location: Sydney N.S.W.
TOTAL POSTS: 105
Reply | QUOTE
Re: Malfunction Indicator (Dashboard Engine Warning Light)


I got the engine warning light come on today.
I was trying the Sunny Corner Trek with Alex today and there are some pretty steep rock sections on the trail. I got to the top of one of them and stopped for a quick break. Upon starting the warning light came on and immediately the idle dropped to around 500rpm, a bit low and i got a bit of shuddering at that speed so i switched off. Was quite a way from main rd so had to get back. I got back but with a considerable loss of power and the engine was running very rough which made driving a little jerky. When not in gear the idle was all over the place sometimes stayed at 2000rpm and all the way down to 500rpm. My brother-in-law thought that in the fault mode it limits rpm, this sortof makes sense because i found it drove better in a higher gear at lower rev's despite the obvious reduction in power by doing this.

Got back to Katoomba with a bit of hesitation from the car and i got 0102 for the code. Mass Air Flow Circuit Low input. Checked the air filter and was reasonable. Havn't checked what the MAS looks like yet. I reset the fault and the car seems to be running as usual now. Not sure why the fault was triggered yet? Wait and see if it may come back?

---
Mat - X-1358 (C)
2003 T30 Series I ST
King Spring Lift, Pedders Shock Absorbers, BFGoodrich 225/70/16, 16" CSA Platinum Edge Rims, Bash Plate, Alutec Strut Bar, UHF CB Radio, HID Fog Lights, Narva 175mm Lights, Nissan Nudge Bar
31/Oct/2009, 9:49 pm Link to this post Send Email PM   Send Private Message
 
jalalski Profile
Live feed
Blog
Friends
Miscellaneous info


Back To Top
Premium



Date Registered: 02-2004
Location: SUTHERLAND, SYDNEY
TOTAL POSTS: 28797
Reply | QUOTE
Re: Malfunction Indicator (Dashboard Engine Warning Light)


P0102 means that your MAF sensor is either disconnected, something wrong with the wiring of it at the harness or the most likely cause, being contaminated. Check the internal chamber and see if there is any oil residue on the MAF sensor itself.

---

1/Nov/2009, 5:11 pm Link to this post Send Private Message MSN Blog
 
Mat Mat Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL ENTHUSIAST
 

Back To Top

Date Registered: 08-2009
Location: Sydney N.S.W.
TOTAL POSTS: 105
Reply | QUOTE
Re: Malfunction Indicator (Dashboard Engine Warning Light)


I disconnected it and reconnected, but i have not taken the MAF sensor out to inspect it yet. I have seen some after-market ones on ebay for around $100. Not sure what genuine ones cost?
The light hasn't come back on yet.
It is good that you can actually check and reset faults yourself without the need of specialised equipment.

---
Mat - X-1358 (C)
2003 T30 Series I ST
King Spring Lift, Pedders Shock Absorbers, BFGoodrich 225/70/16, 16" CSA Platinum Edge Rims, Bash Plate, Alutec Strut Bar, UHF CB Radio, HID Fog Lights, Narva 175mm Lights, Nissan Nudge Bar
2/Nov/2009, 8:50 pm Link to this post Send Email PM   Send Private Message
 
Robbo0001 Profile
Live feed
Blog
Friends
Miscellaneous info

BANNED USER
Back To Top

Date Registered: 07-2008
Location: Brisvegas, Australia
TOTAL POSTS: 1063
Reply | QUOTE
Re: Malfunction Indicator (Dashboard Engine Warning Light)


I wouldnt look at getting a genuine one if required, I think I was quoted around 300 bucks for sensor alone, and 580 bucks for MAF housing.
Got one (sensor and housing complete) via wreckers hotline, posted from Melbourne, for 90 bucks.
You will need a torx bit to take the MAF sensor out if required, but sounds like you had a loose connection at the housing so hopefully its fixed emoticon I would give it a clean with dedicated MAF Cleaner if an error code comes back, before considering buying another sensor.


---
Dave
99 GU Patrol 2.8TD
Ex-2002 T30 TI Xtrail
3/Nov/2009, 6:35 am Link to this post Send Email PM   Send Private Message
 
Mat Mat Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL ENTHUSIAST
 

Back To Top

Date Registered: 08-2009
Location: Sydney N.S.W.
TOTAL POSTS: 105
Reply | QUOTE
Re: Malfunction Indicator (Dashboard Engine Warning Light)


Not happy,
Well since the light came on the first time it came on once 2 weeks after and has been 6weeks now.
I have had a problem with the idle since though. When in neutral you rev up and insted of rev's dropping back to idle it drops below idle sometimes quite low. Is perfectly driveable apart from that though. Took it to dealer today and they reset ECM and now engine light stays on with same error code for the MAF. Engine is now in malfunction mode so is vitually undriveable sitting at dealers. It is definately not the MAF as i have bought a new aftermarket one and the dealer had a spare on hand to test out another one.

They are thinking there could be a problem with the ECM itself?

Last edited by Mat Mat, 16/Dec/2009, 8:40 pm


---
Mat - X-1358 (C)
2003 T30 Series I ST
King Spring Lift, Pedders Shock Absorbers, BFGoodrich 225/70/16, 16" CSA Platinum Edge Rims, Bash Plate, Alutec Strut Bar, UHF CB Radio, HID Fog Lights, Narva 175mm Lights, Nissan Nudge Bar
16/Dec/2009, 7:44 pm Link to this post Send Email PM   Send Private Message
 


Reply




Page:
 1  2  3  4 ... 7  8  9 





You are not logged in (login)

forum sticker
Back to top Back to top

Back to top

<-- end container -->