Runboard.com
You're welcome.
Australian X-Trail Website Members Rides

Site Search

Facebook Aussie Forum Website Twitter Aussie Forum Website YouTube Aussie Forum Website Flickr PhotoBucket MSN Messenger Skype RSS Feed Events Calendar Admin Mailbox Nissan Australia myNissan Capped Service Fuel Consumption Monitor Tyre Size Calculator Australian X-TRAIL Forum Live Chat





Forum Rules   
   Register for a free global account (learn about it) | LOG IN: globally (click here) (Lost Password?)

 
TeamCMBC Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL NEWBIE
 


Date Registered: 05-2017
Location: Melbourne Vic
TOTAL POSTS: 10
Reply | QUOTE
posticon Fuel consumption issue?


Hey everyone- just changed spark plugs on the x-trail. (2009 2.5 cvt)

Car has more response now - but fuel consumption is through the roof

approx 13.8ltrs per 100 for city/freeway

Am trying to get the car to be more fuel efficient as I keep reading that tests have got results of 10.xx ltrs per 100.

What are some suggestions that I should be looking into?

TIA emoticon

---
Matt
Member ID: X-5100
2009 T31 Adventure Ed CVT
Melbourne Vic
14/Jul/2018, 6:47 pm Link to this post Send Email PM   Send Private Message Blog
 
Revhead Kev Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL HOLIC
 


Date Registered: 10-2006
Location: Mona Vale, Sydney, AUSTRALIA
TOTAL POSTS: 5406
Reply | QUOTE
Re: Fuel consumption issue?


How many kms has it done Matt ?

---
Kev X450(c) T30 Guru
03 Titanium Ti T30 Series 1 **MODIFIED**
My Blog
My CarPC Worklog
14/Jul/2018, 8:29 pm Link to this post Send Email PM   Send Private Message Blog
 
warren xtrail Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL NEWBIE
 


Date Registered: 11-2018
TOTAL POSTS: 3
Reply | QUOTE
Re: Fuel consumption issue?


Hi
I thought if you put fresh plugs in, fuel consumption should improve, Im confused.
29/Dec/2018, 2:37 pm Link to this post Send Email PM   Send Private Message Blog
 
Revhead Kev Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL HOLIC
 


Date Registered: 10-2006
Location: Mona Vale, Sydney, AUSTRALIA
TOTAL POSTS: 5406
Reply | QUOTE
Re: Fuel consumption issue?


Not straight away.
The fuel trims in the ECU could be high from the bad plugs and need time to settle back to normal settings.
The quick way is to reset the ECU following the procedure in this forum of removing a couple of fuses. Search the forum for "ECU reset" to find the thread and instructions for your Xtrail model.

---
Kev X450(c) T30 Guru
03 Titanium Ti T30 Series 1 **MODIFIED**
My Blog
My CarPC Worklog
30/Dec/2018, 8:54 am Link to this post Send Email PM   Send Private Message Blog
 


Reply





You are not logged in (login)

forum sticker
Back to top Back to top

Back to top

<-- end container -->