Runboard.com
You're welcome.
Australian X-Trail Website Members Rides

Site Search

Facebook Aussie Forum Website Twitter Aussie Forum Website YouTube Aussie Forum Website Flickr PhotoBucket MSN Messenger Skype RSS Feed Events Calendar Admin Mailbox Nissan Australia myNissan Capped Service Fuel Consumption Monitor Tyre Size Calculator Australian X-TRAIL Forum Live Chat

Forum Rules   
   Register for a free global account (learn about it) | LOG IN: globally (click here) (Lost Password?)




Page:
 1  2  3 

 
duxbac Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL ENTHUSIAST
 

Back To Top

Date Registered: 02-2004
TOTAL POSTS: 288
Reply | QUOTE
Re: engine cuts out when idling


had,both crank and cam sensor changed,and have taken it for a couple of trips,and x-trail running like a bird.I hope this is the end of all this,i can only [sign in to see URL] and fingers crossed.
25/Jan/2009, 3:47 pm Link to this post Send Email PM   Send Private Message
 
Revhead Kev Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL HOLIC
 

Back To Top
Premium


Date Registered: 10-2006
Location: Mona Vale, Sydney, AUSTRALIA
TOTAL POSTS: 5370
Reply | QUOTE
Re: engine cuts out when idling


Hi Ray,

Does it feel as though it has more power now as well ?

---
Kev X450(c) T30 Guru
03 Titanium Ti T30 Series 1 **MODIFIED**
My Blog
My CarPC Worklog
25/Jan/2009, 10:26 pm Link to this post Send Email PM   Send Private Message Blog
 
duxbac Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL ENTHUSIAST
 

Back To Top

Date Registered: 02-2004
TOTAL POSTS: 288
Reply | QUOTE
Re: engine cuts out when idling


No more power,but appears to be smoother,or its in my imagination,no it is smoother with out a dought,and i now believe one of the sensors was the trouble but time will [sign in to see URL] did i not see a code [sign in to see URL] is idleing better [sign in to see URL]
26/Jan/2009, 12:25 pm Link to this post Send Email PM   Send Private Message
 
Revhead Kev Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL HOLIC
 

Back To Top
Premium


Date Registered: 10-2006
Location: Mona Vale, Sydney, AUSTRALIA
TOTAL POSTS: 5370
Reply | QUOTE
Re: engine cuts out when idling


You may have still been getting pulses from the sensors Ray, so no fault registered, but they may have been delayed to the ECU hence the problems with the engine and it now being smoother.

---
Kev X450(c) T30 Guru
03 Titanium Ti T30 Series 1 **MODIFIED**
My Blog
My CarPC Worklog
26/Jan/2009, 9:37 pm Link to this post Send Email PM   Send Private Message Blog
 
duxbac Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL ENTHUSIAST
 

Back To Top

Date Registered: 02-2004
TOTAL POSTS: 288
Reply | QUOTE
Re: engine cuts out when idling


I have now done a thousand ks since the crank sensors were changed,have had no trouble at all.I was going to change my fuel filter but the mechanic said to wait and see if the fault showed up again and if i have no trouble just do it when i have the next service.

I would say the fault is fixed so i am glad it is all [sign in to see URL] engine is running very well,and does idle like it [sign in to see URL] i had a crank sensor fault with out the computer logging a fault,one to remember and one that was driving me mad and a car engine cutting out is no [sign in to see URL]
21/Feb/2009, 7:31 am Link to this post Send Email PM   Send Private Message
 
tempry Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL NEWBIE
 

Back To Top

Date Registered: 01-2010
TOTAL POSTS: 2
Reply | QUOTE
Re: engine cuts out when idling


I realise this is an old post but I came accross it whilst searching the forum. My 02 Xtrail is experiencing the exact same problem with the exception the idle is very erractic and when it cuts out it is when the revs reduce when pulling up at stop/giveway signs.
No fault codes are being registered either on my mechanics scan tool or the nissans diagnostic computer. We replaced both sensors approx 6 weeks ago but have since then had to replace a head gasket, was your vehicle idling funny ? because if it was maybe during the course of the head removal and replacement, the sensors may have been disturbed or damaged.

Paul
31/Jan/2010, 10:21 am Link to this post Send Email PM   Send Private Message
 
duxbac Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL ENTHUSIAST
 

Back To Top

Date Registered: 02-2004
TOTAL POSTS: 288
Reply | QUOTE
Re: engine cuts out when idling


It has been nearly 12months since i had the crank angle sensor and the cam sensor [sign in to see URL] is running like a bird and ready to tick over 150k,still has the bosch plugs in i installed just before the sensor [sign in to see URL] no oil beteen oil changes,has plenty of power,and good fuel economy.I am more than happy with my [sign in to see URL] was the crank sensor with out a [sign in to see URL]
1/Feb/2010, 9:08 am Link to this post Send Email PM   Send Private Message
 
Dunoon Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL ENTHUSIAST
 

Back To Top

Date Registered: 06-2005
Location: Orange, NSW
TOTAL POSTS: 269
Reply | QUOTE
Re: engine cuts out when idling


My Series 1 2002 let my wife down today, it is her vehicle to drive.
It stalled twice previously while coasting (round-a-bout & street crossing) but restarted straight away. Today in a shopping centre car park it stalled and would not re-start.
She called the NRMA and the guy sprayed either into the air cleaner and it re-started. He said he thought it was a fuel pump.
The engine management light come on and stayed on this time, but not previously.
I drove it to the local dealer in Orange who correctly guessed it was one of the sensors. After "code" checking they found a faulty Crank Angle Sensor which was replaced.
Surprisingly, they had one in stock and I was impressed by the fact that they found time to do it on what was a very busy day for them.
I was told that Nissan recommend a second "mate" to it also be fitted but the service guy suggested that not be done if it was working ok, which it seemed to be doing.
Cost was $280 which I was told was mostly the part as the fitting did not take all that long (from the time they rang to tell me what it was to the time they rang to tell me it was ready.
I am still very happy with the X-trail after over 130,000 ks.
PS: The service guy told me that he had never seen a fuel pump go on an X-trail.

---
John,
From Orange NSW.
My rides are:
2002 TI Auto (Series 1) in Twilight, and
2007 Maxima in Bright Silver
2008 Piaggio MP3 400 in Black
Member number: X165
11/Feb/2010, 10:41 pm Link to this post Send Email PM   Send Private Message MSN Blog
 
jalalski Profile
Live feed
Blog
Friends
Miscellaneous info


Back To Top
Premium



Date Registered: 02-2004
Location: SUTHERLAND, SYDNEY
TOTAL POSTS: 29058
Reply | QUOTE
Re: engine cuts out when idling


Hi Guys,

There are a couple of existing good threads discussing the Crank Position Sensor replacement and symptoms which can be found in the search results [url=[sign in to see URL]

---

12/Feb/2010, 6:22 am Link to this post Send Private Message MSN Blog
 
duxbac Profile
Live feed
Blog
Friends
Miscellaneous info

X-TRAIL ENTHUSIAST
 

Back To Top

Date Registered: 02-2004
TOTAL POSTS: 288
Reply | QUOTE
Re: engine cuts out when idling


dunoon i think you got ripped off,although this was just over 12months ago,i was charged 56dollars each for the sensors and they were then fitted to the head and the engine block and the total cost was about 160 [sign in to see URL]
13/Feb/2010, 8:33 am Link to this post Send Email PM   Send Private Message
 


Reply




Page:
 1  2  3 





You are not logged in (login)

forum sticker
Back to top Back to top

Back to top

<-- end container -->